"Class Does Not Support Automation or Expected Interface" Error Message

Last Updated: 
Tuesday, September 19, 2017

Software/Versions Affected:

This error can have a number of different causes but in most of the cases this means one of the components installed by Optics is out of data (e.g. overwritten by another program) or could not be found. Try to install the following critical components:

  1. Uninstall Optics5 completely
  2. Download and install from the Microsoft website the newest Service Pack for your operating system.
  3. Download and install from the Microsoft website "MDAC2.7
  4. Download and install from the Microsoft website "Jet 4.0 Service Pack 3 Update"
  5. Download and install from the Microsoft website "Windows Script 5.6" for Windows2000 and XP or for Windows 98, ME and NT4.0
  6. Install Optics and restart your computer